JRE运行环境出错导致无法安装STM32CubeMX解决方法

一、问题

安装 STM32CubeMX 一直提示需要安装JAVA运行环境,提示界面如下:

但实际上已经正确安装了JRE,如下为JAVA版本。

问题原因:我的电脑上具有很多版本的JRE,并且有一个版本注册表信息出错,所以无法正常卸载。

二、解决方法

1、先完整卸载目前已安装的JAVA版本,可利用官方提供的卸载工具。

如上图所示,电脑里安装了4个版本的JRE,只需安装最新版的就好,其他直接卸载。

2、如果出现无法卸载的版本,一般是注册表出错,此时可以使用微软系统修复工具,也可以手动修改注册表,建议第一种。

修复之后使用之前的卸载工具可以看到,此时电脑里已经不存在任何版本的JRE。

3、再次安装JRE,根据系统版本下载对应的安装文件,STM32CubeMX需要的最低版本为1.7.0_45,建议直接安装最新版。

三、STM32CubeMX的安装

在正确安装好JRE后,STM32CubeMX的安装非常简单,官网下载,解压,双击安装。

永不止步步 发表于04-21 11:36 浏览1407次
分享到:

已有0条评论

暂时还没有回复哟,快来抢沙发吧

添加一条新评论

只有登录用户才能评论,请先登录注册哦!

话题作者

永不止步步
金币:67185个|学分:184448个
立即注册
畅学电子网,带你进入电子开发学习世界
专业电子工程技术学习交流社区,加入畅学一起充电加油吧!

x

畅学电子网订阅号